SC430はICH7Rを使ったRAIDを組めません

SC430のSouthチップはIntel ICH7"R" MH82801GRですが,ICH7Rを利用したRAIDを構築することはできません。
BIOS Rev.A00ではRAIDモードを選択できないのでIDEモード設定onlyになります(SC430でICH7Rの機能を利用したRAID構築方法をご存知でしたら,ぜひ教えてください)。
SC430製品ページでは「ICH7Rを利用したRAID」については一切触れられていません。製品詳細の「製品概要と特徴」には「OSの機能を利用したRAID」だけしか書かれていません。
OS RAID※により2台のSATA HDDもしくはSCSI HDDでRAID 0またはRAID 1を構築可能。
※工場出荷時のオプションではありません。OS RAIDに対応しているOSでのみ可能、また、お客様ご自身での設定作業が必要となります。
また,注文時にもRAID構成は選択できませんし,青CDのRAIDマニュアルにはWindows Server 2003/Red Hat Enterprise Linux 4 のソフトウェアRAIDに関することのみ記述があります。
 SC420はRAIDを組めたのに・・・SC430兄弟機のPrecision 380もRAID構築できるのに・・・。

RAIDを安く構築するなら,玄人志向 SATA2RE2-PCIe,SATA2RI2-PCIeがいいかもしれません。PCI Express x1カードですので,他に使い道があまりないx1スロットを利用できますし。RAID機能なしのSATA2I2-PCIeならPCI Express x8/x4/x1スロットのいずれでも動作しました。

この記事へのコメント

  • SC420 Maniacs

    あいにく、この組み合わせはもう全然所有してなくて計測できません。SASカード+SATA HDDのデータなら計測した記憶があるので探せばでてきそうなんですが。こちらでもいいでしょうか?
    2009年01月04日 23:12
  • くま

    先日はありがとうございました。
    RAID1にて無事構築できましたが
    HDDの速度について気になりましたので
    もしよろしければどの程度出ているか
    教えて頂けませんでしょうか。

    こちらの環境では
    hdparm -t /dev/sda1
    /dev/sda1:
    Timing buffered disk reads: 100 MB in 0.88 seconds = 113.10 MB/sec

    という結果でした。
    2009年01月03日 02:03
  • SC420 Maniacs

    いけましたか。ようやくRAIDを組めますね。おめでとうございます。
    2008年12月27日 20:26
  • くま

    玄人志向 SATA2RI2-PCIEを購入し
    取り付けた所RAID側BIOSにも入れました。

    チップは先日のPCIと同じ
    PMC Pm39LV010-70JCEでした。
    2008年12月27日 19:52
  • くま

    って、このページに思いっきり
    PCI ExpressのRAIDカード書いてありますね

    購入も検討してみます。
    2008年12月27日 01:08
  • くま

    そうですねぇ。
    CentOS5インストール時にドライバを自動で読み取り、HDDが2台正常に見えてますのでSATAカードとしては機能しているようです。

    (結局、PCI接続なので利用する価値もなさそうで、取り外しましたが)

    SC430でPCI ExpressのRAIDカード動作報告をまだ見たことがないので(見つけられてないだけかも)どうかわからないですが

    今回のはチップとSC430の相性のようですね。

    ハードウェアRAIDは諦めて、ソフトウェアRAIDで構築してみます。
    2008年12月26日 23:46
  • SC420 Maniacs

    結局、くまさんのご希望がかなわなくて残念でしたね。

    本体とカードの相性なのかも!?
    2008年12月26日 23:16
  • SC420 Maniacs

    RAIDは不可なのにSATAカードとしては利用できるんですね。こんなケースもあるんですね。

    SC430側になんらかの制限がついているのかもしれませんね。PCI ExpressのRAIDカードならどうなるでしょうね。
    2008年12月26日 23:14
  • くま

    追記です。
    正常にRAID側のBIOSに入れるPCにて
    updflashを実行したところ
    SC430のときは認識されなかったのがウソのように
    BIOS Updateできてしまいました・・。

    その後SC430に取り付けてみましたが
    やはりRAID側BIOSには行けないため

    現時点まで行った作業からの結論では
    SC430にてSATARAID4P-PCIカードの
    チップPMC Pm39LV010-70JCEでは
    SATAカードとしては利用出来ても
    RAIDカードとしては利用出来ない

    という事になりそうです。
    2008年12月26日 22:34
  • くま

    カード側のアップデートも試したのですが
    updflushにて現在のチップを認識してもらえず
    アップデートできない状況にあります。

    玄人思考のBBSでも同じチップ
    (PMC Pm39LV010-70JCE
    )の方がいまして
    その方が解決法を書かれているのですが

    こちらの環境ではそれでも不可でした。

    updflashは5種類ほど試してみましたが
    どれもできず、他のPCにこのカードをつけてみたところ、RAID側のBIOSへ正常に入れたため
    カード側は問題ないと思い、BIOSアップデートは断念しました。

    2008年12月26日 22:02
  • SC420 Maniacs

    公開されているかどうかわかりませんが、カード側のBIOSアップデートでしょうか。アップデートしてもうまく表示される可能性は?ですが。SiliconImage Sil3114チップということなので探せばころがっていそうです。
    2008年12月26日 21:27
  • くま

    CMOSクリアでも改善されませんでした。

    他に何か行える事はないでしょうか。
    2008年12月26日 20:59
  • くま

    カードを別のスロットに差し替える
    シリアルポートをOFF
    フロントUSBをOFF
    は行ってみましたが改善されませんでした。

    これからCMOSクリアを試してみます。
    2008年12月26日 20:35
  • SC420 Maniacs

    SC430のBIOSでシリアルポートなどをとりあえずOFFにしてみるとか。
    2008年12月26日 20:27
  • SC420 Maniacs

    ・カードを別のスロットに差し替える
    ・CMOSクリアする

    ぐらいでしょうか。
    2008年12月26日 20:24
  • くま

    さらに追記です。
    Knoppixを使い、BIOSをA04へ更新しましたが
    やはり同様の症状のままです。
    2008年12月26日 20:21
  • くま

    追記です。

    BIOSの初期化(初期設定へ戻す)も試しましたが、やはり同様の症状です。
    2008年12月26日 19:07
  • くま

    返事ありがとうございます。
    BIOSをA04へアップデートも考えたのですが、Windows上やLinux上の方法しか探したとき見つからず、FDDからのBIOS更新方法ってあるのでしょうか。(もうOSは何もない状態なので困っています)

    またキーについては電源投入後すぐにF4を押しっぱなしにしてみたり、Ctrl+Sを押しっぱなしにしてみたりと試してみましたが、

    No boot device available -
    strike F1 to retry boot, F2 for setup utility

    となってしまい、ダメでした。
    2008年12月26日 19:01
  • もののけ

    あ、たしかにそれっぽいですね。
    DellのBIOS画面は一瞬で消えたりしますし、使っているモニタによっても映らない時間がけっこうあったりしますね。
    2008年12月26日 18:56
  • SC420 Maniacs

    あとは・・・キーを押していたらRAID BIOS画面が表示されていなくてもBIOS画面に入れたりしますがどうでしょうか?
    2008年12月26日 18:20
  • もののけ

    SC430のBIOS設定を初期化してみてもダメでしょうか。
    あとA04が最新のようです。
    可能ならバージョンアップしてみてください。
    2008年12月26日 15:25
  • くま

    かなり前の記事にレスしてしまい、すいませんが教えて頂ければ幸いです。

    SC430(BIOS A03)にSATARAID4P-PCIを増設しました。

    SC430のBIOS上ではPCIカードにRAIDと書かれているため正常に認識しているのですが

    起動時にF4またはCtrl+Sを押下するようなメッセージが表示されずRAIDカードのBIOS画面に入る事ができないでいます。

    他のPCにSATARAID4P-PCIを取り付けて試した所
    正常にメッセージが表示されBIOS画面に入れましたので、カードの問題とも思えないのですが・・。

    確認した方が良い項目等ありますでしょうか。
    2008年12月26日 14:57
  • 一社員

    N.Y. 様

    いろいろとありがとうございます。どうやらカードの初期不良だったようです。たまたま同じカードを 2 枚買っていたので、違う方に交換してみたらバッチリ動きました。ご迷惑をおかけしました。

    ダメな方は、別のスロットに挿し変えても動かず、BIOS のメッセージが全く表示されませんでした。新しい方は、BIOS のメッセージも表示され、問題なく動作しました。

    それでは、失礼いたします。
    2006年05月17日 12:43
  • N.Y.(管理人)

    BIOS画面の入り方が書いてあります。
    カードによってはBIOS画面を表示させない設定にすることができますので,ひょっとしたら隠し設定なっているのかも?隠れていてもキーを押せばBIOS画面に入れます。
    http://www.kakaku.com/bbs/Main.asp?PrdKey=05679010299

    あと,カード挿し込むPCIスロットを別のスロットにしても同じでしょうか?

    だめならカードが不良なのかも?販売店に相談してみましょう。
    2006年05月16日 20:21
  • 一社員

    ちなみに、パソコンの BIOS バージョンは A02 です。普通であれば、BIOS 画面中に、「Press ...」のようなメッセージが出て、RAID の設定画面に入れますよね? それが出来なくて困っております。
    2006年05月16日 10:55
  • 一社員

    SLOT 3 (PCI 32-bit / 33-MHz) に挿しているのですが、BIOS の画面中に RAID 設定のメッセージが現れず、どうにもこうにも進むことができません。何か私のやり方が間違っているのでしょうか?
    2006年05月16日 10:50
  • N.Y.(管理人)

    実際にカードを使って構築したわけではありませんので憶測になりますがRAIDを組めると思いますよ。

    SATARAID4P-PCIだと何か不具合が出ますでしょうか?
    2006年05月15日 22:06
  • 一社員

    玄人志向の SATARAID4P-PCI を購入して SC430 RAID 組みを失敗した者です。SATA2RE2-PCIe や SATA2RI2-PCIe であれば、SC430 でも RAID を組めるということでしょうか?
    2006年05月15日 18:29
  • N.Y.(管理人)

    もちろん,その通りです。
    Server系OSが必須なので,個人ユースでは手が出ませんね。
    2005年10月21日 23:08
  • nitsen

    OS RAID※によりでしょう!ソフトRAIDですよね
    2005年10月20日 23:11